Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi
  • Page :
  • 1
  • 2
  • 3

SUJET :

PB avec divers erreurs sur nouvelle install il y a 2 ans 10 mois #3957

  • Choukajohn
  • Portrait de Choukajohn
  • Hors Ligne
  • COM_KUNENA_SAMPLEDATA_RANK2
  • COM_KUNENA_SAMPLEDATA_RANK2
  • Messages : 33
  • Remerciements reçus 5
N'y aurait-il pas tout simplement un problème dans le code UTF-8 ?
Erreur : (1366, "Incorrect string value: '\\xE2\\x82\\xAA)')...' => celui-ci ne correspond à rien, il semble y avoir une parenthèse de trop.

Table UTF-8 :
₪ = \xe2\x82\xaa

S'il vous plaît Connexion ou Créer un compte à se joindre à la conversation.

PB avec divers erreurs sur nouvelle install il y a 2 ans 10 mois #3966

  • lag
  • Portrait de lag
  • Hors Ligne
  • COM_KUNENA_SAMPLEDATA_RANK_ADMIN
  • COM_KUNENA_SAMPLEDATA_RANK_ADMIN
  • Messages : 1914
  • Karma: 8
  • Remerciements reçus 463
Bonsoir,

Je n'ai pas de solution à votre souci.
De plus, cela me semble plus un problème lié à MySQL qu'à Diacamma en lui-même.

S'il vous plaît Connexion ou Créer un compte à se joindre à la conversation.

Laurent
Principale contributeur (Développeur) à Diacamma
Administrateur de Sleto partenaire officiel de Diacamma : support et hébergement en ligne.

PB avec divers erreurs sur nouvelle install il y a 2 ans 10 mois #3969

  • Choukajohn
  • Portrait de Choukajohn
  • Hors Ligne
  • COM_KUNENA_SAMPLEDATA_RANK2
  • COM_KUNENA_SAMPLEDATA_RANK2
  • Messages : 33
  • Remerciements reçus 5
Bonsoir,

Je pense avoir trouvé la solution.
Par défaut à la création d'une base de données dans MySQL l'encodage est en latin9.

Pour afficher l'encodage actuel de la DB :
SELECT default_character_set_name FROM information_schema.SCHEMATA S WHERE schema_name = "DBNAME";

La mienne était bien en latin9.

Je l'ai donc convertie en utf8mb4 afin de supporter tous les caractères Unicode en suivant ce tuto :
mathiasbynens.be/notes/mysql-utf8mb4

Le plus simple est de créer une base vierge et de la convertir directement puis de réinstaller une instance pour restaurer une sauvegarde.

J'ai eu une erreur à la fin de la création des tables dans la DB mais tout semble fonctionnel :
django.db.utils.OperationalError: (1139, "Got error 'empty (sub)expression' from regexp")

J'essaye de restaurer une sauvegarde plus tard et je posterai le résultat.

Edit :
J'ai essayé de restaurer ma sauvegarde mais j'obtiens la même erreur que ci-dessus et la restauration ne se fait pas.
Pourtant quand je me connecte à Diacamma, tout semble fonctionner, l'assistant se lance, toute les fonctionnalités sont accessibles et aucune erreur n’apparaît.

Une idée ?

S'il vous plaît Connexion ou Créer un compte à se joindre à la conversation.

Dernière édition: par Choukajohn.

PB avec divers erreurs sur nouvelle install il y a 2 ans 10 mois #3970

  • Choukajohn
  • Portrait de Choukajohn
  • Hors Ligne
  • COM_KUNENA_SAMPLEDATA_RANK2
  • COM_KUNENA_SAMPLEDATA_RANK2
  • Messages : 33
  • Remerciements reçus 5
Bonjour,

J'ai abandonné avec MySQL et je suis passé à PostgreSQL, je crois que c'est ce qu'il y a de mieux à faire, d'autant plus que Postgre est open source.
J'ai réinstallé une instance propre configurée avec Postgre et j'ai rétabli ma sauvegarde sans encombre, tout est parfaitement fonctionnel.

J'ai mis à jour le tuto avec l'installation de PostgreSQL, création d'une DB et utilisation avec Diacamma sur :
www.choukajohn.me/index.php/2018/08/03/i...linux-ubuntu-debian/
Cet utilisateur a été remercié pour son message par: lag

S'il vous plaît Connexion ou Créer un compte à se joindre à la conversation.

  • Page :
  • 1
  • 2
  • 3
Temps de génération de la page : 0.040 secondes
Propulsé par Kunena

Qui sommes nous?

Le sanglier du Libre

Association éditant le logiciel Diacamma
12 rue Marius Charles
38420 Domène
France

Partenaire

SLETO

Si vous rechercher du support ou une solution d'hébergement pour Diacamma, faite confiance à SLETO, notre partenaire officiel