Bienvenue, Invité
Nom d'utilisateur : Mot de passe : Se souvenir de moi
  • Page :
  • 1

SUJET :

Fonctionnement en mode réseau il y a 2 ans 7 mois #5173

  • La beaunette
  • Portrait de La beaunette Auteur du sujet
  • Hors Ligne
  • COM_KUNENA_SAMPLEDATA_RANK1
  • COM_KUNENA_SAMPLEDATA_RANK1
  • Messages : 18
  • Remerciements reçus 0
Bonjour,
J'ai migré l'application d'une VM Linux 18.04 à un serveur physique Linux 20.04. Tout fonctionne correctement sauf le lancement automatique de l'application au démarrage du serveur le Batch suivant ne fonctionne plus quelqu'un a-t-il une idée sur ce qui ne marche pas ? Merci d'avance pour votre aide.

#Script lancement Serveur Diacamma
#Lancement virtual lucterios
cd /var/lucterios2/
source virtual_for_lucterios/bin/activate
#Lancement par gunicorn du lanceur lucterios instance syndic1
DJANGO_SETTINGS_MODULE='syndic1.settings' gunicorn lucterios.framework.wsgi --bind=0.0.0.0:8000 --daemon
#Sortie Virtual lucterios
deactivate

S'il vous plaît Connexion ou Créer un compte à se joindre à la conversation.

MMA
Dernière édition: par lag.

Fonctionnement en mode réseau il y a 2 ans 7 mois #5182

  • lag
  • Portrait de lag
  • Hors Ligne
  • COM_KUNENA_SAMPLEDATA_RANK_ADMIN
  • COM_KUNENA_SAMPLEDATA_RANK_ADMIN
  • Messages : 2019
  • Karma: 8
  • Remerciements reçus 506
Bonsoir,

Le batch ne fonctionne pas, mais il dit quoi suite à son execussion ?

Personnellement, j'utilise supervisor : voir ce tutoriel , cela simplifie beaucoup le démarrage.

S'il vous plaît Connexion ou Créer un compte à se joindre à la conversation.

Laurent
Principale contributeur (Développeur) à Diacamma
Administrateur de Sleto partenaire officiel de Diacamma : support et hébergement en ligne.

Fonctionnement en mode réseau il y a 2 ans 7 mois #5183

  • La beaunette
  • Portrait de La beaunette Auteur du sujet
  • Hors Ligne
  • COM_KUNENA_SAMPLEDATA_RANK1
  • COM_KUNENA_SAMPLEDATA_RANK1
  • Messages : 18
  • Remerciements reçus 0
Merci pour cette réponse, justement le problème c'est :
qu'il ne dit rien et fait rien!

S'il vous plaît Connexion ou Créer un compte à se joindre à la conversation.

MMA

Fonctionnement en mode réseau il y a 9 mois 3 semaines #5669

  • NicolasLecomte67
  • Portrait de NicolasLecomte67
  • Hors Ligne
  • COM_KUNENA_SAMPLEDATA_RANK1
  • COM_KUNENA_SAMPLEDATA_RANK1
  • Messages : 1
  • Remerciements reçus 1
Salut !

Peut-être que le service gunicorn ne se lance pas comme prévu. T'as pensé à vérifier les logs pour voir s'il y a des messages d'erreur ? Aussi, assure-toi que les chemins dans ton script sont corrects et que les permissions sont bien set. Oh, et vérifie si gunicorn est bien installé dans ton environnement virtuel. Si tout semble ok, teste ton script ligne par ligne directement dans le terminal, ça pourrait t'aider à trouver où ça coince.

A plus et bonne chance avec ça !
Cet utilisateur a été remercié pour son message par: lag

S'il vous plaît Connexion ou Créer un compte à se joindre à la conversation.

  • Page :
  • 1
Temps de génération de la page : 0.066 secondes
Propulsé par Kunena

Qui sommes nous?

Le sanglier du Libre

Association éditant le logiciel Diacamma
12 rue Marius Charles
38420 Domène
France

Partenaire

SLETO

Si vous recherchez du support ou une solution d'hébergement pour Diacamma, faite confiance à SLETO, notre partenaire officiel